Forum Internet Service Backes

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Neuigkeiten:

Autor Thema: XT-C 3.04SP2.1 Prob bei der Installation bei Step 6  (Gelesen 2500 mal)

rodnex

  • Gast
XT-C 3.04SP2.1 Prob bei der Installation bei Step 6
« am: 11 Oktober, 2006, 22:56:55 Nachmittag »

Hallo,

ich bin bei dem Webspace Anbieter all-inkl.com und habe dort das SQL5 System.
Habe den full package Download genutzt und nach der Anleitung hier im Forum das Ganze soweit vorbereitet.
Sprich: Entpacken, Hochladen, Rechte setzen usw.
Weiterhin habe ich eine neue Datenbank angelegt und mit der Installation begonnen.

Soweit so gut, die Installation lief auch einwandfrei, aaaaber beim Step 6 erhalte ich eine Fehlermeldung.

Und zwar "Der Server unter www.meinedomain.dehttp konnte nicht gefunden werden".

Ich habe schon zig Varianten der Webserver Einstellungen durchprobiert, aber es klappt irgendwie nicht.
Den Shop kann ich bereits aufrufen, erscheint aber rein html ohne images usw.

Hat da jemand vielleicht einen güldenen Tipp für mich?

Danke schonmal im Voraus!
Gruß Rodion
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: XT-C 3.04SP2.1 Prob bei der Installation bei Step 6
« Antwort #1 am: 12 Oktober, 2006, 08:00:57 Vormittag »

nun, mich soll jemand korrigieren, wenn ich mich irre, aber:

ab step 6 wird als "pfadquelle" erstmals die frisch generierte configure.php verwendet. (wird in step 5 generiert?!)

damit würde ich darauf schliessen, dass die pfadangaben in den vorigen steps nicht stimmt/gestimmt hat.
Gespeichert

genndus

  • Admin
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 492
    • PC & Internet Service Backes
Re: XT-C 3.04SP2.1 Prob bei der Installation bei Step 6
« Antwort #2 am: 12 Oktober, 2006, 14:45:49 Nachmittag »

Hallo,

normalerweise erkennt die Installation den Pfad ja schon richtig.
Zitat
Und zwar "Der Server unter www.meinedomain.dehttp konnte nicht gefunden werden".
Das sieht nach einem groben Schnitzer bei der Angabe der Pfade aus, oder war das ein Schreibfehler beim stellen der Frage?

kannst eine Textdatei erstellen mit dem Inhalt:
<?php
  phpinfo
();
 
?>

Und als phpinfo.php auf dem Server im Shopverzeichnis speichern. und über den Browser aufrufen.
Dort stehen dann alle möglichen Pfade drin.
Von wo aus das Skript gestartet wurde auch, unter "apache2handler" "SCRIPT_FILENAME" 
das sieht dann zum Beispiel so aus: SCRIPT_FILENAME /srv/www/htdocs/web99/html/shop/phpinfo.php 
Bei diesem Ergebnis müsste die configure.php in includes und in admin/includes etwa so aussehen die in Admin/includes hat einen Eintrag mehr oder so.
<?php
/* --------------------------------------------------------------

  XT-Commerce - community made shopping
  http://www.xt-commerce.com

   Copyright (c) 2003 XT-Commerce
  --------------------------------------------------------------
  based on:
  (c) 2000-2001 The Exchange Project  (earlier name of osCommerce)
  (c) 2002-2003 osCommerce (configure.php,v 1.13 2003/02/10); www.oscommerce.com

  Released under the GNU General Public License
  --------------------------------------------------------------*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
  
define('HTTP_SERVER''http://www.deine-domain.de'); // eg, http://localhost - should not be empty for productive servers
  
define('HTTPS_SERVER''https://www.deine-domain.de'); // eg, https://localhost - should not be empty for productive servers
  
define('ENABLE_SSL'false); // secure webserver for checkout procedure?
  
define('DIR_WS_CATALOG''/shop/'); // absolute path required
  
define('DIR_FS_DOCUMENT_ROOT''/srv/www/htdocs/web99/html/shop/');
  
define('DIR_FS_CATALOG''/srv/www/htdocs/web99/html/shop/');
  
define('DIR_WS_IMAGES''images/');
  
define('DIR_WS_ORIGINAL_IMAGES'DIR_WS_IMAGES .'product_images/original_images/');
  
define('DIR_WS_THUMBNAIL_IMAGES'DIR_WS_IMAGES .'product_images/thumbnail_images/');
  
define('DIR_WS_INFO_IMAGES'DIR_WS_IMAGES .'product_images/info_images/');
  
define('DIR_WS_POPUP_IMAGES'DIR_WS_IMAGES .'product_images/popup_images/');
  
define('DIR_WS_ICONS'DIR_WS_IMAGES 'icons/');
  
define('DIR_WS_INCLUDES',DIR_FS_DOCUMENT_ROOT'includes/');
  
define('DIR_WS_FUNCTIONS'DIR_WS_INCLUDES 'functions/');
  
define('DIR_WS_CLASSES'DIR_WS_INCLUDES 'classes/');
  
define('DIR_WS_MODULES'DIR_WS_INCLUDES 'modules/');
  
define('DIR_WS_LANGUAGES'DIR_FS_CATALOG 'lang/');

  
define('DIR_WS_DOWNLOAD_PUBLIC'DIR_WS_CATALOG 'pub/');
  
define('DIR_FS_DOWNLOAD'DIR_FS_CATALOG 'download/');
  
define('DIR_FS_DOWNLOAD_PUBLIC'DIR_FS_CATALOG 'pub/');
  
define('DIR_FS_INC'DIR_FS_CATALOG 'inc/');

// define our database connection
  
define('DB_SERVER''localhost'); // eg, localhost - should not be empty for productive servers
  
define('DB_SERVER_USERNAME''web99');
  
define('DB_SERVER_PASSWORD''*********');
  
define('DB_DATABASE''usr_web99_1 ');
  
define('USE_PCONNECT''false'); // use persistent connections?
  
define('STORE_SESSIONS''mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Also entweder die Installation noch mal komplett durchführen, oder die beiden configure.php von Hand anpassen, und da weitermachen wo Du aufgehört hast.

Gruß
Genndus
Gespeichert
www.pc-service-backes.de
xtc Installations- Service und Fehlersuche.
Preiswerter Webspeicherplatz
xtc 3.04sp2.1 ist auf den meisten Webspace-Paketen vorinstalliert.
Shop

rodnex

  • Gast
Re: XT-C 3.04SP2.1 Prob bei der Installation bei Step 6
« Antwort #3 am: 14 Oktober, 2006, 21:57:53 Nachmittag »

Hallo,

vielen Dank für eure Tipps! Jetzt läuft alles!

Ich war wohl mal wieder auf Klugscheissmodus und hab gemäß der Beispiele die Sources usw. eingetragen.
Dabei war die automatische Erkennung seitens XTC aber die beste Lösung!

Grüße Rodion
Gespeichert