Forum Internet Service Backes

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Neuigkeiten:

Autor Thema: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt  (Gelesen 13202 mal)

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« am: 26 Oktober, 2006, 20:30:53 Nachmittag »

Hallo,

ich benötige bitte Hilfe.
Seit neuestem sehe ich die neu angemeldeten Kunden nicht mehr im Adminbereich unter Kunden. Sie sind zwar in der Datenbank vorhanden aber werde die Suche noch die Sortierung bringen die neue Kunden zur ansicht.
Woran kann das liegen?

Danke

EDIT: Auch wenn ich die customers.php noch einmal drüber kopiere bringt nichts.

XTC 304SP1
« Letzte Änderung: 26 Oktober, 2006, 20:50:12 Nachmittag von MAD King »
Gespeichert

Haareraufer

  • Gast
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #1 am: 27 Oktober, 2006, 07:53:54 Vormittag »

Hallo,

du hast aber nicht zufällig auf der Seite den Filter für die Kundengruppen falsch eingestellt. oder?

(*nur mal so frag*)

Gruß

Norbert
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #2 am: 27 Oktober, 2006, 08:16:12 Vormittag »

hallo,

hast du vielleicht änderungen an den scripts gemacht

entweder
1) alle die mit create_account.php zu tun haben

oder
2) im adminbereich mit customers?


hatte mal das problem, dass ich versucht habe kunden in den shop zu importieren, dabei aber die customers_info - tabelle nicht bedient habe, sondern nur customers... ergebnis: die kunden wurden nicht angezeigt!

gruss
rené
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #3 am: 27 Oktober, 2006, 12:05:01 Nachmittag »

Hi,

also ich habe jetzt alle Dateien aus dem original XTC 304SP1 Ordner drüber kopiert und das gleiche Problem. Ich sehe nach dem 22.10 keine neuangemeldeten Kunden.
Verstehe wirklich nicht woran das liegt. In der DB sind sie ja vorhanden.
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #4 am: 27 Oktober, 2006, 12:26:35 Nachmittag »

ist hier jemand der den cache verwendet? ich verwende ihn nicht, deswegen, keine ahnung, aber könnte es sein, dass durch einen fehler immer wieder die gecachte-version vom 22.10 verwendet wird?!
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #5 am: 27 Oktober, 2006, 12:33:19 Nachmittag »

bei mir sind aber keine Dateien im /cache drin.

EDIT: Ich bekomme auch seit neuesten keine Emails mehr, wenn sich Kunden neu anmelden.
« Letzte Änderung: 27 Oktober, 2006, 12:35:07 Nachmittag von MAD King »
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #6 am: 27 Oktober, 2006, 12:53:31 Nachmittag »

also, du bist dir sicher, dass du zu JEDEM Eintrag in der tabelle customers auch einen in customers_info hast?! ist wichtig an dieser stelle...

wenn nicht, würde ich mal stück für stück die /catalog/create_account.php prüfen. diese ist bei neukunden sowohl für die eintragung in der db, als auch für die neukundenmail verantwortlich.
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #7 am: 27 Oktober, 2006, 13:01:53 Nachmittag »

also, du bist dir sicher, dass du zu JEDEM Eintrag in der tabelle customers auch einen in customers_info hast?! ist wichtig an dieser stelle...

wenn nicht, würde ich mal stück für stück die /catalog/create_account.php prüfen. diese ist bei neukunden sowohl für die eintragung in der db, als auch für die neukundenmail verantwortlich.


Komischerweise steht wirklich nichts in der customers_info zu den Anmeldungen nach dem 22.10. Ich wüsste aber auch nicht, dass ich etwas an der create_account.php verändert hätte.
Wie bekomme ich jetzt die Kunden von der cunstomers in die customers_info Tabelle?
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #8 am: 27 Oktober, 2006, 13:06:25 Nachmittag »

ich hab's ja gleich gesagt ;)

um erst einmal die fehlenden zu integrieren reicht es in der customers_info für jeden kunden eine zeile anzulegen, wo folgende werte gesetzt sind:
 customers_info_id (= customers_id aus tabelle customers) und
 customers_info_date_account_created (= anmeldedatum, hier kannste irgendwas eintragen... z.b.: "2006-10-09 18:00:46")

damit sollten die kunden wieder im adminbereich sichtbar sein.

was jetzt mit deiner create_account.php ist, kann ich dir auch nicht sagen...
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #9 am: 27 Oktober, 2006, 13:11:51 Nachmittag »

ALso ich habe die create_account.php zusammen mit einer anderen Datei als Contrib oder Modul irgendwo runtergeladen. Es schreibt automatisch Kundernnummern in Form von KD-xxxxx in die DB.

In die create_account.php wurde nur das zusätzlich eingefügt:

Zeile 49:

require_once (DIR_FS_INC.'dith_new_customer.php');

Zeile 220: 'customers_cid' => dith_get_new_customer_number());


      $sql_data_array = array ('customers_vat_id' => $vat, 'customers_vat_id_status' => $customers_vat_id_status, 'customers_status' => $customers_status, 'customers_firstname' => $firstname, 'customers_lastname' => $lastname, 'customers_email_address' => $email_address, 'customers_telephone' => $telephone, 'customers_fax' => $fax, 'customers_newsletter' => $newsletter, 'customers_password' => xtc_encrypt_password($password),'customers_date_added' => 'now()','customers_last_modified' => 'now()',   'customers_cid' => dith_get_new_customer_number());

Meinst du es liegt daran? Zumal die Datei vom 18.10 stammt und wie gesagt die Anmeldungen bis 22.10 angezeigt werden.
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #10 am: 27 Oktober, 2006, 13:28:59 Nachmittag »

ich hab's ja gleich gesagt ;)

um erst einmal die fehlenden zu integrieren reicht es in der customers_info für jeden kunden eine zeile anzulegen, wo folgende werte gesetzt sind:
 customers_info_id (= customers_id aus tabelle customers) und
 customers_info_date_account_created (= anmeldedatum, hier kannste irgendwas eintragen... z.b.: "2006-10-09 18:00:46")

damit sollten die kunden wieder im adminbereich sichtbar sein.

was jetzt mit deiner create_account.php ist, kann ich dir auch nicht sagen...


Habe ich gemacht. Die customers_info ist aktualisiert und habe auch die original create_account.php wieder drüber aber ich sehe immer noch keine Kunden nach dem 22.10.
Lag also nicht daran. Mist!
Gespeichert

thuhn01

  • Hero
  • *****
  • Offline Offline
  • Beiträge: 500
    • Was man ohne Lizenzgebühren so alles im Internet machen kann
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #11 am: 27 Oktober, 2006, 14:17:45 Nachmittag »


Zeile 220: 'customers_cid' => dith_get_new_customer_number());


Poste bitte mal Dein komplettes $sql_data_array aus Zeile 220.

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #12 am: 27 Oktober, 2006, 14:24:40 Nachmittag »

glaube nicht, dass es an dem array liegt, die customers tabelle wird ja noch gefüllt, nur die _info tabelle nicht mehr...

aber auch die orig create_account.php brachte bei ihm nichts, sagt er...
Gespeichert

MAD King

  • Member
  • ***
  • Offline Offline
  • Beiträge: 99
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #13 am: 27 Oktober, 2006, 14:26:13 Nachmittag »

Ich habe sie einfacherhalber gleich angehängt. Aber daran kann es ja auch nicht liegen, denn selbst mit der original Datei aus dem Ordner von XTC 304SP1 bleibt es bestehen. Ich sehe keine User vor dem 22.10
Gespeichert

SNCJansen

  • Global Moderator
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 424
    • Mein Arbeitgeber ;)
Re: HILFE-Neue Kunden werden im Admin nicht mehr angezeigt
« Antwort #14 am: 27 Oktober, 2006, 14:33:28 Nachmittag »

ok,

tabelle customers wird befüllt, customers_info nicht...
in der create_account.php wird zwischen diesen beiden tabellen die tabelle address_book befüllt???

vielleicht kommen wir so näher ran an das problem...
Gespeichert
 

User Contact