Forum Internet Service Backes

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Neuigkeiten:

Autor Thema: Summe netto wird nicht angezeigt  (Gelesen 2798 mal)

ChrisFah

  • Member
  • ***
  • Offline Offline
  • Beiträge: 36
    • Ballon4u
Summe netto wird nicht angezeigt
« am: 11 Juli, 2008, 13:19:38 Nachmittag »

Hallo, ich bin schon verzweifelt:
Bei mir im shop xtc Sp2.1 (dl von hier) wird mir die Zwischensumme netto (ot_subtotal_no_tax) im Admin und auf der shopeigenen Rechnung nicht angezeigt.
Das Modul ist in Zusammenfasung installiert und aktiviert (reihenfolge vor Summe und vor MWst).

Woran kann das liegen???

Lg, Chris
Gespeichert
Hmm, das weiss ich nicht, ob ich mir das antun will...

genndus

  • Admin
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 492
    • PC & Internet Service Backes
Re: Summe netto wird nicht angezeigt
« Antwort #1 am: 11 Juli, 2008, 20:55:37 Nachmittag »

Hallo,

hast Du die Zahlen für die Reienfolge richtig angegben?
Sonnst kann ich mir auf die Schnelle nicht vorstellen woran es liegen könnte.

Gruß
genndus
Gespeichert
www.pc-service-backes.de
xtc Installations- Service und Fehlersuche.
Preiswerter Webspeicherplatz
xtc 3.04sp2.1 ist auf den meisten Webspace-Paketen vorinstalliert.
Shop

ChrisFah

  • Member
  • ***
  • Offline Offline
  • Beiträge: 36
    • Ballon4u
Re: Summe netto wird nicht angezeigt
« Antwort #2 am: 12 Juli, 2008, 20:56:16 Nachmittag »

Bei mir exakt wie auf dem Bild.

Weder im bestehenden Shop, noch im neuen (noch nicht öffentlichen, aber am Webspace laufenden) shop ist es so.
Auch hab ich die Standardeinstellungen gelassen, aber nix, ich bekomm keine Nettosumme.

Hilfe !!! :-[
Gespeichert
Hmm, das weiss ich nicht, ob ich mir das antun will...

genndus

  • Admin
  • Senior
  • *****
  • Offline Offline
  • Beiträge: 492
    • PC & Internet Service Backes
Re: Summe netto wird nicht angezeigt
« Antwort #3 am: 13 Juli, 2008, 15:42:50 Nachmittag »

Hallo,

hab noch mal genauer nachgesehen und musste feststellen das ich beim letzten mal durch Zeitmangel schlicht und einfach Sch... geschrieben habe es geht nämlich bei mir auch nicht.
Zwischensumme: 1.190,00 EUR
Deutsche Post (Versand nach DE: (1 x 5 kg)): 6,70 EUR
Hier sollte ja dann noch die Summe ohne Märchensteuer angezeigt werden.
inkl. UST 19%: 190,00 EUR
Summe: 1.196,70 EUR

Das geht nur wenn in der jeweiligen Kundengruppe:
Möchten Sie die Preise inklusive oder exklusive Steuer anzeigen?
Preise inkl. MwSt. auf Nein gesetzt ist

Und
Falls Preis inkl. Steuer = auf "Nein" setzen
UST in Rechnung ausweisen auf Ja gesetzt ist.

Dann Sieht das so aus:
Zwischensumme: 1.000,00 EUR
Deutsche Post (Versand nach DE: (1 x 5 kg)): 6,70 EUR
Summe, netto: 1.006,70 EUR
zzgl. UST 19%: 190,00 EUR
Summe, brutto: 1.196,70 EUR

Hier war für die Versandkosten keine Steuer eingeschaltet sonst werden diese auch hinzu gerechnet.

Die Anzeige ist also nur für Kundengruppen Möglich die Nettopreise im Shop angezeigt bekommen.
Ist mir nie aufgefallen scheint allgemein so zu sein.
In diversen anderen Foren bin ich auch noch nicht fündig geworden.
Die Frage wird oft gestellt, aber keine wirkliche Lösung angeboten.

Edit: Noch was auf ecombase gefunden:
http://www.ecombase.de/forum/index.php?showtopic=3271&hl=ot_subtotal_no_tax

Gruß
genndus
« Letzte Änderung: 13 Juli, 2008, 15:58:13 Nachmittag von genndus »
Gespeichert
www.pc-service-backes.de
xtc Installations- Service und Fehlersuche.
Preiswerter Webspeicherplatz
xtc 3.04sp2.1 ist auf den meisten Webspace-Paketen vorinstalliert.
Shop

ChrisFah

  • Member
  • ***
  • Offline Offline
  • Beiträge: 36
    • Ballon4u
Re: Summe netto wird nicht angezeigt
« Antwort #4 am: 21 Juli, 2008, 22:43:08 Nachmittag »

Hallo Genndus,
danke für den Tip, ich habs so wie SirOliver gelöst. Nur war ein kleiner Denkfehler bei ihm im Netto-Kunden Teil drin.
Anbeimeine Lösung für die ot_subtotal_no_tax:
   function process() {
// ot_subtotal_no_tax immer anzeigen unabhängig von Kundengruppen Einstellung
// Änderungen by ChrisFah (office@ballon4u.eu)
global $order, $xtPrice;

// für Netto Kunden
if ($_SESSION['customers_status']['customers_status_show_price_tax'] == 0 && $_SESSION['customers_status']['customers_status_add_tax_ot'] == 1) {
  if ($_SESSION['customers_status']['customers_status_ot_discount_flag'] == 1) {  // mit ot_Rabatt
    $sub_total_price = $order->info['subtotal'] - ($order->info['subtotal'] / 100 * $_SESSION['customers_status']['customers_status_ot_discount']);
  } else {  // ohne ot_Rabatt
   // $sub_total_price = $order->info['subtotal'] - ($order->info['subtotal'] / 100 * $_SESSION['customers_status']['customers_status_ot_discount']);
   $sub_total_price = $order->info['subtotal'];
  }
        $this->output[] = array('title' => $this->title . ':',
        'text' => '<b>' . $xtPrice->xtcFormat($sub_total_price+($xtPrice->xtcFormat($order->info['shipping_cost'], false,0,true)), true).'</b>',
        'value' => $xtPrice->xtcFormat($sub_total_price+($xtPrice->xtcFormat($order->info['shipping_cost'], false,0,true)), false));
}

// für Brutto Kunden  Summe netto wird immer angezeigt
if ($_SESSION['customers_status']['customers_status_show_price_tax'] != 0 ) {
   $sub_total_price = $order->info['total']-$order->info['tax'];

   $this->output[] = array('title' => $this->title . ':',
   'text' => '<b>' . $xtPrice->xtcFormat($sub_total_price, true).'</b>',
   'value' => $xtPrice->xtcFormat($sub_total_price, false));
}
}
Ungetestet, sollte aber funken. Es sollte jetzt immer angezeigt werden.

Lg, Chris
Gespeichert
Hmm, das weiss ich nicht, ob ich mir das antun will...
 

User Contact